Scheduled for January 20, 2026 at 10:55 PM – January 21, 2026 at 2:40 AM
Affects
Minecraft
Under maintenance from 10:55 PM to 2:40 AM
Completed
January 21, 2026 at 2:40 AMCompleted
January 21, 2026 at 2:40 AMMaintenance has completed successfully.
In progress
January 20, 2026 at 11:04 PMIn progress
January 20, 2026 at 11:04 PMMaintenance has now started
Planned
January 20, 2026 at 10:55 PMPlanned
January 20, 2026 at 10:55 PM2b2t is going to be preforming maintenance on the server hardware to hopefully improve on the lag - your patience is appreciated